{{wiki}} helper empty

[10.10 11:08] Djordje Karadzic

Dear community

When developing our custom CatalogItem using your plugin API, we tried to get the data from the field defined as ‘content’ in the blueprint definition. However, there is no ‘content’ field in CatalogItemType.java nor does Handlebars return any value when we type {{content}}.

Interestingly, when the plugin is deactivated and a ‘content’ is added in the Blueprint, we see that there is some data. Based on the HTML code when the plugin is deactivated, we concluded that it must be the {{wiki}} Handlebars helper that contains the data we are looking for. However, it is always empty when the plugin is activated, and we eventually receive a NullPointerException when trying to use it, although we have added data to the ‘content’. When we add the {{hasWiki}} elements, we no longer have the NPE but there is still no data.

Is there anything wrong with our Handlebars parser or is that a general issue?

Hi there,

Thanks for the question. Are you able to share your handlebars template so we can see how you are using the {{wiki}} helper?

Hi @ctaylor !

Sure, it’s just as it is in your examples:

    <div class="catalog-item-content wiki-content">


If you don’t choose your Plugin provided catalog item layout on the Catalog Item Blueprint, and leave it as the Morpheus standard, does the content show?

Yes, it does.

What data are you providing in the content field? If you can’t share your full template here, please can you send it privately to me? Ideally id like to see your full plugin code if possible. Thanks!

I have compiled your Plugin and I can get the content wiki to work. What error are you specifically getting in the logs and what content are you providing in the catalog item type?

When trying without the hasWiki helper, we receive a NullPointerException. With the hasWiki helper no exception, but no content either. The content added to the blueprint is a simple plain text, such as:

'This is the content that should be displayed as a tooltip help text at the top of the page’.


Here is your catalog item layout working within my 5.4.11 appliance: Screen Shot on 2022-10-21 at 16-05-02.png - Droplr. The only thing I can see is that the tool-tip you have added does not seem to operate correctly. I am not sure what is going wrong for you, as I can see my content “Hello World!”. Can you provide a video that showcases:

  1. You configuring the blueprint
  2. With a terminal running “morpheus-ctl tail morpheus-ui” on one of the Morpheus Appliance app nodes you ordering one of the catalog items.
  3. What you are missing from the catalog item order UI.


We fixed it by upgrading to 5.4.11 (we had 5.4.4 before). Ultimately, the issue has been resolved :slight_smile:. Thank you for the hint and help!