VM provisioning works Ubuntu 16.04 but fails with 18.04, 20.04 and 22.04

Hello Experts, I have a urgent questions to ask regarding VMware cloud. I am trying to deploy various flavors or Ubuntu images. When I deploy VM with ‘Morpheus Ubuntu 16.04.6 v1’ image provided by Morpheus, it works as expected and I notice that size of template is 2.23GB. VM is assigned with IP address and I am able to access it normally.

But When I tried to deploy Morpheus provided VMware templates for 18.04, 20.04 or 22.04, I noticed size of template is 1.83KB and I am not able to boot the VM.

Am I missing something here. It is same thing with CentOS 7.5 images I am able to boot but other CentOS images like 8 and 9 having the same issues. Is there anything I need to take care while using old version templates vs new version of templates ?

Is the datastore out of space?

Are the esxi hosts resolvable from from Morpheus and have 443 open from Morpheus to connect and do an ovf import?

Are you using the images with build dates? Those are the most current images.

There is a lot of free space in datastore:

I verified that ESXi hosts are reachable from Morpheus:
[root@morpheus-54-mgt ~]# ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=0.245 ms
64 bytes from icmp_seq=2 ttl=64 time=0.242 ms
— ping statistics —
2 packets transmitted, 2 received, 0% packet loss, time 999ms
rtt min/avg/max/mdev = 0.242/0.243/0.245/0.015 ms
[root@morpheus-54-mgt ~]#

Also Morpheus is reachable from ESXi host:
[root@localhost:~] ping morpheus-54-mgt.helionit.io
PING morpheus-54-mgt.helionit.io ( 56 data bytes
64 bytes from icmp_seq=0 ttl=64 time=0.290 ms
64 bytes from icmp_seq=1 ttl=64 time=0.366 ms

morpheus-54-mgt.helionit.io ping statistics —
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 0.290/0.328/0.366 ms

I am simply selecting version of operating system not by build date and it works for 16.04 and doesn’t work for others:

Some of the following may help.

  • Try to curl to each of your esxi hosts from your Morpheus appliance
    curl -k https://192.168.9.x This should provide an html return

  • Delete the current partial download templates in your vCenter.

  • Provision another of the same type from Morpheus.

  • Check for the following task in vCenter (the status of this task may provide some info on why)

Thanks for support. Yes I did cleaned up all the images from vCenter and tried again, but still the same. 16.04 works and others does not work.

I am able to curl the ESXi hosts from Morpheus server:
[root@morpheus-54-mgt ~]# curl -k

[root@morpheus-54-mgt ~]#

What does the task show in vCenter for the ovf deploy.

Its all completed without error, VM provision fails the same way:

and here is the size of template, which shows 1.83KB:

Hi @piyush.jain . You should’ve had an HTML return on the curl example Bob provided. This seems indicative of not having 443 connectivity from Morpheus to your ESXi host(s).

Something similar to this:

Its same only, Its just that I paste the html snippet it didn’t show it here in my last comment for some reason:

Deleting the template in the vcenter and retrying from Morpheus should result in logs both on Morpheus and vCenter. You should see references to OVF import and this would most likely show the error. If you’re still stuck afterwards, I would recommend raising a support ticket for better triaging.

I checked Morpheus logs, but couldn’t identify the reason, Is there a possibility you to check this once?
Google Drive Current Logs

@piyush.jain - Curious what version of vCenter and ESXi you are running? I do see the following in the log which may indicate a compatibility issue with the vCenter version the OVF was created from and the version you are running.

[Line 132: Unable to parse ‘flags.vvtdEnabled’ for attribute ‘key’ on element ‘Config’. , Line 133: Unable to parse ‘flags.vbsEnabled’ for attribute ‘key’ on element ‘Config’. ]

Thanks for looking into the logs and identify the issue. I would check with our lab team to also validate this at there end.
Here is the version we are using for vCenter and ESXi:
vCenter: 6.5.0, Build: 8815520
Hypervisor: VMware ESXi, 6.5.0, Build: 5146846

That looks to be the problem. Both vvtdEnabled and vbsEnabled dont look like exist until 6.7. Below is a reference from VMware on version support. With that being said 6.5 and 6.7 both went End of General Support on October 15th 2022. I would recommend either upgrading your environment to a currently supported version of vSphere or creating your own custom templates in vCenter and using those in Morpheus.


For reference i am currently running vCenter 7 and have no issues using these templates.

Thanks a lot for support. Its really great.
We would plan to upgrade our environment and test this again.