VM Provisioning failed with Morpheus system image

Hello Experts,

We are now facing an issue that failed to provision vm using Morpheus system image. The vm was created on vCenter but it is showing as follow:

We had confirmed that it could download Morpheus system image from AWS S3 to Morpheus VM directly. One observation from our side is that the size of Morpheus image template in vCenter Datastore is 0.

Any idea about the root cause for this issue would be very appriciated.

Thank you.


Could you please confirm the user used to integrate VMware cloud have sufficient privileges?


Thank you for your swift response.

Yes, we are using admin user to integrate Vmware cloud.

Are the ESXI hostnames resolvable by the Morpheus appliance, and does the Morpheus appliance have 443 connectivity to the ESXI hosts, either directly or via a proxy?

Hi @ctaylor,

Thank you for your reply.

Yes, we confirmed that ESXi hostname is resolvable and 443 ports is also connected between Morpheus appliance and ESXi hosts.

Has this problem been resolved or are the image streams from Morpheus to vCenter still not working?


Hi @ctaylor , yes it is still not working.

Actually the customer already opened support ticket and uploaded the log file there.
Now is waiting for the response.

The image streaming is now working within the customer environment. We have been working with the customer via the support case. In the future when directing a customer to use support, it would be helpful that the community post is referenced in the support case, so we avoid duplicating effort investigating the same problem in two places.