Running the existing terraform configuration using app templates not working

Configuration works fine outside morpheus,but when we try to use the same config in Blueprints.
We are unable to provision infrastructure nothing gets generated on Logs or plan.
Plan not being generated
Error: provisioning - prepare app error: Cannot get property ‘output’ on null object
Tried the configuration with and without output variables

@abhinay-puppaa01 - Its hard to tell exactly what the issue is from what’s provided. Can you provide some additional details.

What version of Morpheus is this?

What version of TF?

Are other TF apps working?

When you create the app using Provisioning - Apps - Add the plan should be displayed before the complete. Does the plan display and properly show the resources that will be created.

I would expect some information in the morphues logs. You may want to add the TF debug log option here is the docs link and if you add the entry’s under Terraform to your logback file you should be able to see additional information on the TF run. logback config — Morpheus Docs documentation

Also if you can provide the TF code (or a simplified version that produces the same results) and the blueprint configuration you have setup in Morpheus that would help. On older versions of Morpheus there are some unsupported TF variable types.

Tf version 1.1
This our first deployment to morpheus.
Plan is not being displayed.

I was able to resolve this morpheus instance was not connected to internet.
Manually installing the things worked thanks for the help