Renaming ethernet adapters to ethX

In the Morpheus documentation (see Creating a Morpheus VMware Image — Morpheus Docs documentation ( it recommends disabling “consistent device naming” and manually renaming adapters so they appear as eth0. However this is not recommended by RedHat, on this page they state a server where it has been done will NOT be supported. Chapter 1. Consistent network interface device naming Red Hat Enterprise Linux 8 | Red Hat Customer Portal. What exactly is the problem with leaving consistent device naming enabled? thanks Mike

The cloud-init that Morpheus uses to configure provisioned VMs seems to add an alias to the first network interface as determined by cloud-init. I don’t believe consistent network device naming needs to be disabled. In the system images, net.ifnames=0 is not set as a boot parameter. Those names are still on the provisioned VMs.

Hello Nick,

Thanks for confirming my thoughts, been running with consistent network device naming for a good number of weeks without issue.


Hi, Nick.
Where can I find details on how Morpheus is creating and alias for the first NIC?

I am setting up a VM from Ubuntu published Cloud-init image and I have to disable consistent network device naming in order to get VM on the network with static IP.

Mike S.