Morpheus instances - actions button is missing

After upgrading the morpheus appliance to latest version, missing the actions dropbox(which allows start, stop, restart and open vm console).
System admin has no issue, can see this functionalty. But regular users are unable to launch the instance due to missing option to start vmware instance.
Any idea? I have provisioned role access as provisioning > remote console > full access but it did not help.

Hello @binder, thanks for posting!

Can you please confirm the version that you upgraded to? You mentioned the latest but the LTS and the Feature branch have difference.

That said, if it was 5.5.2 or 5.5.3, there many new RBAC controls implemented. Take a look at your roles the users have and see if the Power Control permission is granted on them in the Lifecycle feature permissions. This is from our documentation:
Provisioning > Power Control allows for the stopping/starting/restarting/suspending of Instances and/or Servers.

This can be set to Full, User, or None. Full will grant them to be able to do it on all instances/server they have access to, even ones provisioned by other users. User will permit it on the ones they’ve provisioned only. None will not allow it at all.

Here are some more details from our documentation if it helps:

Look at their Role permissions (Administration > Roles). We’ve recently added more Instance-related Role permissions to increase granularity of control. Under the Provisioning category of permissions you’ll find them. I suspect some of your users have the required permissions for any and all Instance actions disabled.

Yeah, I noticed RBAC interface looks changed.
Under Lifecycle, I do have “power control” accesss setup to Users, but it does not seem to help. Do I need to update any other setting as well along with it.?

I don’t see “powercontrol” under provisiong section tho ?

The Power Control will only be under Lifecycle. There should be no other settings needed. I tested an example here on a Role with no permissions, except for the following:

Provisioning > Instances: List (allows the user to be able to access the instances at all)
Lifecycle > Power Control (allows the power options to appear)

Role with only Provisioning > Instances: List (Actions missing):

Role with Provisioning > Instances: List and Lifecycle > Power Control:

As @aharker mentioned, there are many more options you can turn on for the instance as well, but I’m just using Power Control in this example. If you feel you are still not getting your expected result, I’d recommend submitting a support ticket to help resolve it.

The button isn’t there when the user has no access to anything that would be inside the menu. As long as you have one thing turned on it should appear.