Cypher Plugin - Failed to create cypher

I’m working on creating a Cypher plugin for Thycotic Secret Server. I’m to the point where I can retrieve the secret, but when after I return the new CypherObject I get “Failed to create cypher” in the UI. Anything I can enable to get some more information on what’s going on? No exception is being thrown from my CypherModule class (I hit the logging point that’s immediately before returning the object).


Hello! . Sorry for the delay as some of us got hit with COVID. Could you elaborate on the morpheus appliance version you are testing on as well as the plugin core model? We did do a recent improvement here in 5.4.7

After coming back to this, I’m not sure what I was doing. I upgraded my appliance to 5.5.0-1 and was able to get things working without a problem and I’m able to retrieve a secret through a shell script!

Design question for you. If I want to be able to retrieve other properties of a secret (i.e. domain, user, pass). How would you recommend doing that? I’m thinking just adding another bit onto the path with which property to retrieve. For example, myplugin/mysecret/domain, myplugin/mysecret/username, myplugin/mysecret/password. Thoughts?

Edit: Also should mention, glad you all are recovering!

Great question. So there are 2 ways to do this. If your data payload is in json I believe our api can deserialize and let you access properties on it. Or you can indeed add some magic to how the path is handled with sub paths to read the values. This is kinda up to your creativity :).

Awesome work on getting Thycotic support going! We are still brainstorming ways to make some of these plugins easier to develop and improve documentation so any feedback is much appreciated.

And thank you! The engineering team somehow avoided it until recently. Hopefully it runs its course and we can get back to full steam ahead.

OK, I ended up just using the path to allow access to different fields. Would you mind giving it a quick review?

Also, I tried adding the credential support (under Infrastructure > Trust), but couldn’t get anything to show up. Under plugin info it shows as “UNKNOWN” and no integration options are available. Maybe a license issue (we are on essentials right now)?

Hmm, tried to use your github link but it seems i dont have access rights to look.

Whoops, should be available now.