Cannot apply community license

Hello, I just setup my test morpheus lab, after installed web UI didnt give option to login morpheus hub so I dont have chance to apply community license.
I tried version 6.0.5 then 5.5.2, both same, after install web ui directly go to create master tenant menu.
Could you please advise how I apply community license in test lab setup?

Is there anything in this document that could help?

Hi Ollie, yes I have seen this document before.
As I mention in my question, first time access in web UI give me page create master tenant menu, so I didnt have option login to morpheus hub for apply community license ( page 6 of the doc ).
Did I miss something?

I’m not sure what could have been missed. Could you have already been logged in to the morpheushub during the installation so that registration/login was unnecessary. Is there definitely not a 25 WLE license applied when you visit Admin > Settings > License?

Hi , here I attach admin license page, as my observe no license installed.
on installation progress, I am not aware any login morpheus hub prompted.

Don’t know TBH. Out of interest which OS are you installing on? I’ll set up a new appliance when I get a moment and walk through the process again.

Hi Ollie, thanks for interest, I am on RHEL 8.8… have tried morpheus version: 6.2.1-1, 6.0.5-1, 5.5.2-1, 5.5.0-1 with cleanse option and rm -rf each reinstall but I dont get any morpheus hub login when initial launch web-gui.

Hi on RHEL 8.7 and 6.2.1 I reached the page after install see the screengrab, so unless its an issue with RHEL 8.8, I don’t know.

But, note the URL in the browser. I wonder if you can navigate to that (/setup/hubMode) and kick off the login or register with hub process that way?

Hi Ollie, yes …/set/hubMode direct me to Morpheus Hub setup, trying login, but in the web-gui still no license.

I will try with rhel 8.7 when got time.


I already installed on rhel 8.7 with morpheus 6.2.1 as well but still doesnt get community license.
Here the detail after install finish (rpm -i, morpheusctl reconfigure),

launch first web GUI
it redirect me to url address
so I have no option to login morpheus hub.

I revise url address to …setup/hubMode, but it always failed login with correct username and password

here the capture from VM console, I able to connect morpheus hub directly with browser.

continue setup with morpheus hub login skipped, no license installed

Is there any other way to get community license?

Hi, are you behind a proxy, I’ve just been speaking with my colleagues and that could be the issue. If so it’s probably better to request a license in the Hub. Once approved you’ll be able to paste that into the license section.

Use this link:

Hi, ollie. yes correct I am behind proxy.
Thanks a lot for suggestion , sure I will try request.

I’ve added in ideas, but it has also just occurred to me, that in the appliance once the master tenant and super user are setup , you could configure the proxy and then try hit that /setup/hubLogin url again. Maybe it would complete with the proxy in place, and assign a license to your appliance. That is all just guesswork, but maybe worth a try. Proxy is configured on Admin > Settings > Appliance (tab)

Hi Phillips, I 'll try both your suggestion.
For setup proxy, after I logging in Morpheus Hub page, it directly give me portal login page, but when I login license still show not installed.

For request license, seems the page for POC but i request anyway with explanation and reference to this thread, hope get equivalent community license from there.
it still on pending status.