VM Console wasn't shown in Morpheus Portal

Hello,

Please kindly advise.

Morpheus is integrated with the vCenter 6.5 version and was able to provision the instance. However, can’t open the VM console through Morpheus Portal.

Morpheus was able to access the managed instances using SSH. (bi-direction).
Also tried with auto-login disabled from the custom role.
Restarted the guacamole service on all 3 nodes by following the steps: Remote Console — Morpheus Docs documentation
Also checked morpheus-ui current log and guacamole current log with the guacamole debug option. (Ref: Morpheus Support )

I received only the below messages when I checked the guacamole logs after killing the process and restarting the service. Didn’t get any further logs, or messages.

#Messages
guacd[16899]: INFO: Guacamole proxy daemon (guacd) version 1.2.0 started
guacd[16899]: INFO: Listening on host 127.0.0.1, port 4822

Thanks,
Aung

Is there no option for console? Or is it just a black screen? Are you using a console gateway?

It is just a black screen. @cbunge… and no console gateway.

If you edit the VM do you have an RPC IP address for the VM? Typically that means we either didn’t sync an IP early enough in the process or SSH connectivity isn’t there.

I will check this option. If the RPC IP Address doesn’t exist, what should I do to get the RPC address automatically during instance provision?

There could be a few reasons if it is empty. Failed to register IP in the OS (failed to set static, or get DHCP, or report back via VMtools for example).

Additionally, if SSH/WinRM port connectivity fails it may cause the RPC host IP to not fill as we were not able to find a valid route to the VM.

To add to Chris’ info. If you edit the underlying VM and have the RPC port listed but still does not work using auto connect, it may have to do with the username/password configured.

When provisioning, if you had Create User check marked, it would create the username/password under your User Settings in the VM. This can be used for auto connect.

If your user was not created in the VM, you can edit the VM in Morpheus and put a username and password in the configuration. However, it could be automatically populated when provisioning by:

  • Ensuring the username and password are configured in Administration > Settings > Provisioning > cloud-init Settings for Linux and Windows settings for Windows

  • If the above settings are not configured and you chose to have your user created, it may populate that automatically in those fields instead

  • The username and password are configured on the Virtual Image that the VM was deployed from

Finally, you can override these by filling in the Guest Console settings manually when editing the VM.

Hello @kgawronski, I confirmed that I set the username and password under the user profile setting in Morpheus Portal before I provisioned and also defined cloud-init username/password under Administration > Provision Setting. That user was also created in the instance. That’s why I can log in to the instance using that user from the Morpheus appliance OS level through SSH command. Furthermore, I also used the Morpheus image (not the custom image).

I will check the Host RPC setting and will update back.

Another point: If we use SSH with a custom port (not port 22) for the Morpheus appliance. It can be related?

Regards,
Aung

We only test against standard ports. Most likely your RPC host IP isn’t getting set because of the change.

Hello @cbunge, I checked the environment today and the RPC setting was set with the cloud-init user at the VM host level. The issue still persists even though we use default port 22 in the Morpheus appliance and then we enabled some ports and changed some configurations at the load balancer then it worked.

Thanks for your support. @kgawronski @cbunge

Regards,
Aung