Create Catalog with Ansible and an Input

Hi All,
I am trying to create a Catakog item based on Ansible code, i want to have some inputs added by end user when executing the playbook as a catlog item.
I have created a Task and Workflow and have a input defined and associated.
When the end user is accessing the Catalog, he can not see the input.
I am using MorpheusData 6.0.1.
How do I achieve this.

You have to add the inputs to the catalog and map the variables where you need them in the configuration payload.

Hi @cbunge,
Thanks for real quick reply.
I am quite new here, just heard about morpheus data couple of weeks ago and doing PoC to prove this could be the solution we are looking for.
Here is what i have done so far.
Created a task pointing to a Playbook (coming from github).
Then a workflow pointing to the task created earlier, No input created here.
And in advanced config “allow custom config” is selected.
Then a new Catalog Item, using the earlier Workflow, added input now.
this is under config
“vCenter_user_pass”:“<%= customOptions.Password %>”
and in the ansible playbook
vCenter_user_pass: “{{ morpheus[‘customOptions’][‘Password’] }}”

the issue is i still cant see input option when i order catalog item.
I had created another catalog to deploy CentOS and used hostname as input and it worked there.
Appreciate your help in pointing to correct this.
Any documentation which is more than what is available on docu which i can refer to.

i got my problem, the input i had created was of wrong type, hidden changed to password and now it is working.
This is resolved now.