Naming with sequences doesn't follow the same sequence into the chef integration

In a nutshell, if I create a naming sequence for the deployment, and apply the chef integration with that same sequence, the sequence will be off between the two.


This may deploy as azlnxtsdws018 for the instance name, but will integrate in chef as azlnxtsdws02.

Does anyone know the reasoning behind why this wouldn’t know why the sequence wouldn’t follow into chef with the same sequence, and is there a point / phase of the deployment that I could perform the deployment and use the real name variable from the instance? It seems that even in post-provision it is still using the sequencing variable. I want to keep the sequencing if possible, but I definitely need them to match across chef and morpheus.

Actually now that I go back and break it down to the simplest form of creating a catalogue blueprint using the configuration wizard with the sequence naming and including the native chef integration that is known to work outside with non-catalogue items doesn’t even appear to try to bootstrap the instance. This is without adding any additional workflows. Does anyone actually have the native chef integration functional within catalogue items, or are you creating bootstrap tasks for a workflow that you are adding to the catalogue item?

I also attempted to set the variable in an alternate task prior to the boostrap task in the workflow. It is setting the variable but not passing this properly to a chef bootstrap task. Still no luck. If I place the variable in the node location it prompts me upon selecting the workflow with the bootstrap task for the node information. I have tried leaving that empty and specifying the variable with and without quotes to no avail. Today is just not my day I guess… :slightly_smiling_face: