AWS Integration

Hi i am getting below error when i add aws account to Morpheus

Error! Unknown error connecting to amazon

Morpheus logs from Administration -> Health -> Morpheus Logs would probably give a more specific error. If it’s a connection error, it seems like Morpheus can’t reach the AWS endpoints.

1 Like

If you do track down a more specific error, feel free to update the thread here. First guess would be authentication issue (double check keys, etc.)

Thanks a lot , earlier provided key has access to only s3 but Looks like we need ec2 privilege to add an account , tried with different iam user key and it worked out

To make full use of the AWS integration in Morpheus, see the IAM permission set in our docs: AWS — Morpheus Docs documentation. Depending on what you intend to do, you may be able to limit the permissions further but you’d be able to do everything with those permissions.

FYI. We recently discovered that if you use server-side encryption on S3 buckets your Morpheus user/role will also need the following permissions.

1 Like

Sorry for the delayed response but thanks for calling that out. I’ve added it to our documentation.