Adding NSX integration fails via API

When adding NSX integration (scoped to a project) via API, it fails with an error

"success": false,
"msg": "Error connecting to nsx-t"

When added via GUI with the same details, it authorizes correctly against the NSX manager and we can select a project.

The issue is that it requires passing the systemVersion key within the networkServer.config. The workaround is to pass the systemVersion key and the value should be your NSX manager’s version, like below.

  "networkServer": {
    "name": "integration_name",
    "serviceUrl": "nsx_service_url",
    "zoneId": 18,
    "serviceUsername": "service_username",
    "servicePassword": "service_password",
    "visibility": "private",
    "enabled": true,
    "type": "nsx-t",
    "config": {
      "project": "nsx_project_name",
      "systemVersion": "" #Replace it with your NSX Manager's version

Note: This is not an issue when adding the integration with the admin user. Only for non-admin users who have access to only one project. This is fixed in the upcoming Morpheus releases.